Acoustica - Software should be easy to use

m2wshlex.dll causes Explorer "Edit" function to cr

Support and feedback for Acoustica Audio Converter Pro and MP3 to Wave Converter PLUS.

Moderators: Acoustica Dan, Acoustica Greg, Acoustica Chris, Acoustica Eric

bluesplayer
Posts: 6
Joined: Sat Oct 25, 2008 7:57 pm

m2wshlex.dll causes Explorer "Edit" function to cr

Postby bluesplayer » Mon Sep 28, 2009 4:34 pm

IN Win XP (SP3) on TWO machines (a Dell XPS desktop and Dell 820 laptop) IÔÇÖve been having issues with the Windows Explorer window crashing if I am on any folder that CONTAINS folders and try to use the menu item ÔÇ£EditÔÇØ so that I could do things like ÔÇ£Copy, or Paste, or Select all, etc.

It was a MINOR annoyance but lately it was really interfering with work flow and was a real issues SO I decided to run it to ground.
It seems I wasnÔÇÖt paying attention the pop up debug window when Exploder crashed it actually TOLD me exactly what was crashing. It turns out it is ÔÇ£m2wshlex.dllÔÇØ which is an Acoustic a installed DLL (MP3 to Wav Convertor plus) in any case when I disable it in the context menus (via EITHER regedit and or using NirSoftÔÇÖs ShellExView) I no longer have windows Explorer crashes when using the menu item ÔÇ£EditÔÇØ in the Explorer Window.

IÔÇÖve been able to consistently make Explorer crash, or not, as a function of having the that DLL active in the context shells or not.

ItÔÇÖs a completely repeatable and verifiable issue ÔÇô at least on these two machines in Win XP SP3. Any other reports? Any planned updates for this bug?

Thanks
Larry

User avatar
Acoustica Eric
Site Admin
Posts: 5661
Joined: Wed Mar 22, 2006 4:30 pm
Location: Michigan, USA
Contact:

re

Postby Acoustica Eric » Tue Sep 29, 2009 5:19 am

I personally have this software installed on about 7 machines, 5 are xp pro SP3 and have never had such an issue. It might be that you have something commonly installed on the two dells that is conflicting with our software. Security suits with context menu scan options maybe?

bluesplayer
Posts: 6
Joined: Sat Oct 25, 2008 7:57 pm

Postby bluesplayer » Tue Sep 29, 2009 5:44 pm

I've been living with it and really didn't expect you to acknowledge any issues and to point to other apps that is status quo when reporting problems to any vendor about any app. So first thing I do is trouble shoot, then isolate so it really is the ONLY SW (in this case context menu) item running (other then requireed MS OS related) . And FYI COMODO is my "suite" but it's all disabled for this exercise.

Again it doesnÔÇÖt ALWAYS happen (this is not a RMB issue RMB items works as advertised on MP3 and other audio file types) . It only when folders, and a few other file types, are present in the highlight tree. SO MAYBE if you ever DID have strange behavior you may have simply shrugged it off and attributed "issues" to MS or other apps.

To reconstruct - this is just one way Example (one of many):

Environment: windows Classic view (classic start menu and all files visible - I do not hide system files, or folders, or extensions)

Now Right click on My Computer; Now left click "Explore"; Now left click on Local Disk C (this expands out the folder and make sures it is actually selected/highlighted so we dont' have any empty arguments being paseed):

NOW go up to the menu bar at top and left click "Edit" (like maybe you wanted acess to the "Select All" option it provides) If you don't get a debug crash for "m2wshlex.dll" then your right I'm the only one with this issue (of course this app is the only context item other then the OS running so??) .

A web search indicates a few others, not just me, with issues . Searching on "w2wshslex" yields a couple and the first one is goes back to 2004

http://www.windowsbbs.com/windows-xp/34550-explorer-crash-rmb.html


http://social.technet.microsoft.com/Forums/en-US/itprovistaapps/thread/f586b707-3085-461b-874c-907d53ce4b1e


I'd be happy to send you a debug/crash dump? For now I'll just disable it since I know what is causing MY problem. I'll simply turn it back on when I need it. Unless a patch becomes available (but since you run it on 5 Win XP SP 3 machines it must be the user)

User avatar
Acoustica Greg
Posts: 17166
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Postby Acoustica Greg » Wed Sep 30, 2009 4:51 pm

Hi,

It's not that we're not acknowledging any issues, it's that we're not getting any reports of this problem. It's extremely rare, and we're not able to duplicate it, so there must be something unique about your computers that's causing it. As Eric suggested, it would be instructive to figure out what the two computers have in common, particularly in regard to the Explorer shell. There must be some conflicting software. Can you figure out what it is?


Greg


Return to “Acoustica Audio Converter Pro”

Who is online

Users browsing this forum: No registered users and 1 guest