Page 1 of 3

7.7 Build 296 - Publisher issue

Posted: Tue Jan 26, 2016 9:27 pm
by Anorax
Made a bug report about this, but there's no option for trimming audio during the publishing process. This can be annoying if you have a long tail of silence in the render.

Re: 7.7 Build 296 - Publisher issue

Posted: Tue Jan 26, 2016 9:35 pm
by Mark Bliss
I'm going to have to experiment with this some before fully forming a conclusion. Maybe we need a feature suggestion to add a "render selection" modifier to the upload feature?
But without that, I think I kind of expected it to upload the full project, and the need to crop that long tail of silence would be something normal I think?
How do other DAW's with this kind of publish feature handle this?

Re: 7.7 Build 296 - Publisher issue

Posted: Tue Jan 26, 2016 9:48 pm
by Anorax
No idea how other DAWs do it; at least not from experience.

I think a quick workaround would to be to render the audio like normal (with the "render selection" option enabled) then open a new Mixcraft project to publish it, but that kind of defeats the purpose a bit, especially for publishing to audio-only services like SoundCloud.

I guess I could also adjust my workflow so that I get rid of extra MIDI clips that were used for reference and muted (but not removed from the project); it's these clips that cause the tail of silence to occur.

Re: 7.7 Build 296 - Publisher issue

Posted: Wed Jan 27, 2016 1:06 pm
by Acoustica Greg
Hi,

Wow, that's a huge amount of silence in that bug report screenshot. If you get rid of the extra MIDI clips, does that help?

Greg

Re: 7.7 Build 296 - Publisher issue

Posted: Thu Jan 28, 2016 4:19 pm
by gypsy101
so,other than the publishing why would I need this upgrade?
I tend to do my publishing/posting AFTER I do all my other legalities... I see this as a fault- no offense, but hat got fixed that wasn't working before?

Re: 7.7 Build 296 - Publisher issue

Posted: Thu Jan 28, 2016 4:28 pm
by Acoustica Greg
Hi,

There are a bunch of fixes. The one that some forum users have been waiting for is the fix for moving notes up and down in the piano roll with the mouse. It's always good to get the latest version, because we're constantly fixing things that people report.

I posted a list of additions and fixes here.

Of course, this is a beta version right now. Don't download it unless you want to beta test and try to find bugs.

Greg

Re: 7.7 Build 296 - Publisher issue

Posted: Fri Jan 29, 2016 1:06 pm
by mick
In reply to Mark's question- How do ther DAWs handle publishing?

The other DAW I have has an upload information panel very similar to Mixcraft and does not have an option to make last minute corrections, it assumes the project is ready for presentation and all work has been finalised in the program.
The difference is the other DAW has a header for the song title and comments and Mixcraft has a number of blank mystery panels. I have no idea whatsoever what they refer to. :shock:

EDIT: I just had another look at the Mixcraft panel and there are 2 unreadable squiggles (above and below the spaceman) that look like they may be writing of some sort. Clicking on one asks if private or public and the other looks like it may be quality so Acoustica needs to make this a much bigger font :D

publish.PNG
publish.PNG (49.92 KiB) Viewed 3869 times


samp upload.PNG
samp upload.PNG (53.43 KiB) Viewed 3869 times

Re: 7.7 Build 296 - Publisher issue

Posted: Fri Jan 29, 2016 1:21 pm
by Acoustica Greg
Hi,

Mixcraft's publisher screen should look like this, more or less.

Image

Mick, if your's is blank like that, we need to do some troubleshooting. What version of Windows are you using? You've got build 296 installed, correct? Did you go into Mixcraft's ini files and customize the colors or something?



Greg

Re: 7.7 Build 296 - Publisher issue

Posted: Fri Jan 29, 2016 1:52 pm
by mick
Greg. Whoooops! :oops: Yes I changed the ini file colours! :roll:
I've kept 64 bit and reloaded the 32 bit version and now have this super smart panel. Thank you :D

upload.PNG
upload.PNG (44.59 KiB) Viewed 3859 times

Re: 7.7 Build 296 - Publisher issue

Posted: Fri Jan 29, 2016 2:25 pm
by Acoustica Greg
Hi,

Thanks for letting us know what it was! Let this be a warning to the custom colors crowd. :wink:

Greg

Re: 7.7 Build 296 - Publisher issue

Posted: Fri Jan 29, 2016 2:33 pm
by Mark Bliss
I knew you'd be ready for it when it inevitably popped up Greg...... :D

Re: 7.7 Build 296 - Publisher issue

Posted: Fri Jan 29, 2016 2:51 pm
by Anorax
To answer your question Greg, yes, if I remove the MIDI clips it renders just fine.

I guess the real question is, why does Mixcraft consider muted clips (or muted tracks—well, in this case, a muted submix) when rendering?

Re: 7.7 Build 296 - Publisher issue

Posted: Fri Jan 29, 2016 2:54 pm
by Acoustica Greg
Hi,

Add that comment to your bug report!

Greg

Re: 7.7 Build 296 - Publisher issue

Posted: Fri Jan 29, 2016 3:03 pm
by mick
Ha!ha! :lol: when I was changing some colours there were some stuff I could not relate to so I obviously left them because they didn't appear to make any difference until now. when I discover I messed things up.

I made a list of what was changed and compared them side by side to the original 32 bit version mixskin and this time only changed what was necessary, and the result is that I have my colours back AND the super duper publishing panel so I have 32 and 64 bit versions all working correct to my theme. All is well again. 8)
I guess I forgot about the "If it ain't broke don't fix it" thing. :roll:

Re: 7.7 Build 296 - Publisher issue

Posted: Fri Jan 29, 2016 3:09 pm
by Anorax
So the real question is, is the bug an "enhancement" for controlling mixdown length, or is the bug in Mixcraft including muted tracks and clips when calculating mixdown length?