Acoustica - Software should be easy to use

Mixcraft not saving and freezing Please help

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Dan, Acoustica Greg, Acoustica Chris, Acoustica Eric

Benjamin Drew
Posts: 22
Joined: Sat Mar 16, 2019 3:14 am

Mixcraft not saving and freezing Please help

Postby Benjamin Drew » Sat Mar 16, 2019 3:31 am

Lately it has become unusable. After a half hour or so I'll try to save a project and it will just freeze up windows and I have to force shut down the computer because task manager won't even pull up.

(I can save the project every couple of minutes, but again, after about a half hour or so it won't save anymore work. Trying to save it and or exiting out of mixcraft and trying to save a project, either way will cause this issue.)

I have lost hours of time.

I am troubleshooting the plugins by elimination but I was hoping the admins would look at the log file for any clues I am over looking.

I'm on the latest version of mixcraft 8 Pro 64 bit (418) and windows 10 64 bit. Attached is the log file.

I have a 2018 Dell Inspiron gaming laptop with an i5 processor and 16 gigs of RAM.

Plugins:

1.)T-force alpha
2.)Superwave P8
3.)Dexed
4.)Density MK3
5.)Synth master 1 and 2 plus everything bundle
6.)Akai Advance VIP suite
7.)All the free native instruments plugins (Not sitting in front of my computer right now to list them out)
8.)Nightlife
9.)Slynth1

If there are any others I will list them out when I get home this afternoon. Just trying to be descriptive as possible. Sorry for all the edits.
Attachments
Mixcraft-Log.zip
(7.53 KiB) Downloaded 6 times

User avatar
jlouvar
Posts: 539
Joined: Wed Jul 24, 2013 4:56 pm
Location: California - USA

Re: Mixcraft not saving and freezing Please help

Postby jlouvar » Sat Mar 16, 2019 9:17 am

FWIW: I’ve found Akai VIP isn’t fully compatible with Mixcraft due to non-standard programming and Akai VIP sometimes causes MX to take longer than usual to close. Of course I’m pretty sure this has nothing to do with your freezing/saving problem. Also Acoustica usually ask for logs to be sent to Support rather than posted here. :wink:

Acoustica Greg wrote:Hi,

Get it to happen one more time, then quit Mixcraft and send us your mixcraft-log.txt file.

To find the mixcraft-log file, highlight the following line and press Ctrl+C to copy it:

Code: Select all

%appdata%\Acoustica\Mixcraft\


Press the Windows Key+R to pop up the Run box in Windows. Click in the Run box and press Ctrl+V to paste in the line from above. Finally, click OK to go to the location of the mixcraft-log.txt file. Submit an Acoustica Support Request and attach the log file along with a brief description of the problem.

Greg


I have a feeling the following may have something to do with your freezing/saving problem.

Benjamin Drew wrote:I have found that you can add different folders. I believe I added somewhere around 5 folders at one point for different plugin folder locations. I too use 32 and 64 bit plugins. Right now I have one for Program files x86 VST (32 bit) and Program files VST (64bit).


But of course Acoustica Support will know and help you.
Mixcraft 8.1 Pro (64-Bit Build 418), Lenovo (1.80GHz, 8GB, 64-bit), Windows 10, Focusrite Scarlett 2i4, Event and PreSonus monitors, Korg TR61, Akai MPK249, MPK2 Mini, Fender American P & J basses, Strat, D35, and a lot of microphones, etc.

Benjamin Drew
Posts: 22
Joined: Sat Mar 16, 2019 3:14 am

Re: Mixcraft not saving and freezing Please help

Postby Benjamin Drew » Sat Mar 16, 2019 10:32 am

jlouvar wrote:FWIW: I’ve found Akai VIP isn’t fully compatible with Mixcraft due to non-standard programming and Akai VIP sometimes causes MX to take longer than usual to close. Of course I’m pretty sure this has nothing to do with your freezing/saving problem. Also Acoustica usually ask for logs to be sent to Support rather than posted here. :wink:

Acoustica Greg wrote:Hi,

Get it to happen one more time, then quit Mixcraft and send us your mixcraft-log.txt file.

To find the mixcraft-log file, highlight the following line and press Ctrl+C to copy it:

Code: Select all

%appdata%\Acoustica\Mixcraft\


Press the Windows Key+R to pop up the Run box in Windows. Click in the Run box and press Ctrl+V to paste in the line from above. Finally, click OK to go to the location of the mixcraft-log.txt file. Submit an Acoustica Support Request and attach the log file along with a brief description of the problem.

Greg


I have a feeling the following may have something to do with your freezing/saving problem.

Benjamin Drew wrote:I have found that you can add different folders. I believe I added somewhere around 5 folders at one point for different plugin folder locations. I too use 32 and 64 bit plugins. Right now I have one for Program files x86 VST (32 bit) and Program files VST (64bit).


But of course Acoustica Support will know and help you.


Thank you for the responses. I have already attached a log file to the original post. It happens every time I have it open long enough. I looked at the log file but I can't tell what I'm looking at. It doesn't indicate a real problem. To quit mixcraft I have to hold down the power button on the computer to do a hard restart and then any work I had done isn't saved.

As far as folder options, what do you recommend?

EDIT: I see what you mean now about getting it to happen again. Every time Mixcraft is started it creates a whole new log file. I will work on this immediately.
Last edited by Benjamin Drew on Sat Mar 16, 2019 10:41 am, edited 1 time in total.

User avatar
jlouvar
Posts: 539
Joined: Wed Jul 24, 2013 4:56 pm
Location: California - USA

Re: Mixcraft not saving and freezing Please help

Postby jlouvar » Sat Mar 16, 2019 10:39 am

I suggest that you Submit an Acoustica Support Request and attach the log file along with a brief description of the problem... But if that’s impossible, I recommend waiting until Greg replies here to you (but it’s the weekend so it may not be until Monday or so).
Mixcraft 8.1 Pro (64-Bit Build 418), Lenovo (1.80GHz, 8GB, 64-bit), Windows 10, Focusrite Scarlett 2i4, Event and PreSonus monitors, Korg TR61, Akai MPK249, MPK2 Mini, Fender American P & J basses, Strat, D35, and a lot of microphones, etc.

Benjamin Drew
Posts: 22
Joined: Sat Mar 16, 2019 3:14 am

Re: Mixcraft not saving and freezing Please help

Postby Benjamin Drew » Sat Mar 16, 2019 10:50 am

jlouvar wrote:I suggest that you Submit an Acoustica Support Request and attach the log file along with a brief description of the problem... But if that’s impossible, I recommend waiting until Greg replies here to you (but it’s the weekend so it may not be until Monday or so).

Okay, I couldn't find the support link earlier. Trying to recreate the problem now.

User avatar
jlouvar
Posts: 539
Joined: Wed Jul 24, 2013 4:56 pm
Location: California - USA

Re: Mixcraft not saving and freezing Please help

Postby jlouvar » Sat Mar 16, 2019 10:59 am

Yeah, you need to recreate the problem then quit MX and send the new log file.

https://acoustica.kayako.com/conversation/new
Mixcraft 8.1 Pro (64-Bit Build 418), Lenovo (1.80GHz, 8GB, 64-bit), Windows 10, Focusrite Scarlett 2i4, Event and PreSonus monitors, Korg TR61, Akai MPK249, MPK2 Mini, Fender American P & J basses, Strat, D35, and a lot of microphones, etc.

User avatar
Mark Bliss
Posts: 6151
Joined: Fri Jan 20, 2012 3:59 pm
Location: Out there

Re: Mixcraft not saving and freezing Please help

Postby Mark Bliss » Sun Mar 17, 2019 7:59 am

The project appears to be using a pretty sizeable memory footprint. Though its not a large percentage of your avail mem, I would still suspect there's too much going on in the background. Make sure all other programs, including web browsers etc. are closed and re-evaluate the project. See also the "optimizing your system for Mixcraft" tips elsewhere on this forum page.
The project also shows a lot of third party plug ins that are being disabled. Bias, Guitar Rig, Sylinth, I think Synthmaster, and more.
Be aware guitar sims are known to be memory hogs, as are reverb and some others.

I see you are using your on-board sound card and WaveRT/Core audio. If possible you might try setting your buffers a little higher. 6Ms should be doable with your system specs, but its worth testing to see if your performance/problems improve. You might also consider trying 48K/24bit. I have found improved results in Win10 and using the RealtekHD card in WaveRT/Core audio on my laptop/portable rig using 48/24 instead of 44/16.

Just some thoughts about things to try.
Honestly, I cant deny I too have had problems with Mixcraft freezes, "not responding" crashes and even occasionally just unexpected spontaneous program closing issues on and off for some time that I don't think have been fully diagnosed or explained.
They seem to most often occur when changing sound devices, or after Mixcraft has been sitting idle for an extended period. It has become habit to avoid that for the most part. And save frequently.
For example, I have a session open right now. And since I have opened my browser and checked email, checked this forum, downloaded a project file from a friend, there's a high probability I will go back to Mixcraft and its going to be frozen, probably not responding, and I will have to force it to close and reopen to do any work. Good thing I saved my progress before I made that mistake.
Here we go...….
Yep. Hit play, nothing happens. Had to close the program. At least it closed without drama this time.
Tip is.... dont do that. :lol:

OK, Edit in the interest of full disclosure.
Upon restart, Mixcraft would not recognize the sound device ((RealtekHD sound card in this case) in any mode. Restarting Mixcraft didnt change that. No play, no worky.
Had to restart computer AND switch to Wave, then back to Core/WaveRT. Then it started working again.
That's pretty close to matching the OP's description eh?
I've got to say I think its a buggy driver issue, but I am not certain. Things certainly work more reliably with an interface and ASIO driver in place though...... :roll:
Stay in tune, Mark

Image

My SOUNDCLOUD Page

Benjamin Drew
Posts: 22
Joined: Sat Mar 16, 2019 3:14 am

Re: Mixcraft not saving and freezing Please help

Postby Benjamin Drew » Mon Mar 18, 2019 1:39 pm

The project appears to be using a pretty sizeable memory footprint. Though its not a large percentage of your avail mem, I would still suspect there's too much going on in the background. Make sure all other programs, including web browsers etc. are closed and re-evaluate the project. See also the "optimizing your system for Mixcraft" tips elsewhere on this forum page.
The project also shows a lot of third party plug ins that are being disabled. Bias, Guitar Rig, Sylinth, I think Synthmaster, and more. Be aware guitar sims are known to be memory hogs, as are reverb and some others.


Yeah, I was disabling all the plugins to see if I could root out a bad one.

Question, (Just to be sure)If I disable them within mixcraft and restart mixcraft, they no longer have the ability to cause problems, correct?

I will take another look at the tips for optimization. Though, this wasn't an issue before. I don't think I have ever seen my ram consumption ever go past 6 gigs regardless of what I had going on.

I see you are using your on-board sound card and WaveRT/Core audio. If possible you might try setting your buffers a little higher. 6Ms should be doable with your system specs, but its worth testing to see if your performance/problems improve. You might also consider trying 48K/24bit. I have found improved results in Win10 and using the RealtekHD card in WaveRT/Core audio on my laptop/portable rig using 48/24 instead of 44/16.


I have been trying different sound card settings such as "Asio" "Juno (My Roland Juno)" "Core Audio" and "Wave", Doesn't seem to matter. But again, I will try that as well.

My buffer size is 288 and my latency is 6.5 (5.0 using the Juno DS) and never had a problem. But will still look into it do to added plugins.

Question, I thought about raising the bar to 48K/24bit. But wouldn't that mean I would have to "Dither (Which I know very little about) to mix down to wav 16 bit 44/k? The music service requires that spec (16 bit 44/k) when uploading potential materials for sale.

User avatar
jlouvar
Posts: 539
Joined: Wed Jul 24, 2013 4:56 pm
Location: California - USA

Re: Mixcraft not saving and freezing Please help

Postby jlouvar » Mon Mar 18, 2019 1:57 pm

Note: Its also a good idea to piratically clear your cache.

For example:
https://www.youtube.com/watch?v=z3cjTqC ... dex=3&t=0s
Mixcraft 8.1 Pro (64-Bit Build 418), Lenovo (1.80GHz, 8GB, 64-bit), Windows 10, Focusrite Scarlett 2i4, Event and PreSonus monitors, Korg TR61, Akai MPK249, MPK2 Mini, Fender American P & J basses, Strat, D35, and a lot of microphones, etc.

User avatar
jlouvar
Posts: 539
Joined: Wed Jul 24, 2013 4:56 pm
Location: California - USA

Re: Mixcraft not saving and freezing Please help

Postby jlouvar » Mon Mar 18, 2019 2:02 pm

PS: Were you able to recreate the problem, and if so, did you send the log file to Acoustica Support?
Mixcraft 8.1 Pro (64-Bit Build 418), Lenovo (1.80GHz, 8GB, 64-bit), Windows 10, Focusrite Scarlett 2i4, Event and PreSonus monitors, Korg TR61, Akai MPK249, MPK2 Mini, Fender American P & J basses, Strat, D35, and a lot of microphones, etc.

Benjamin Drew
Posts: 22
Joined: Sat Mar 16, 2019 3:14 am

Re: Mixcraft not saving and freezing Please help

Postby Benjamin Drew » Mon Mar 18, 2019 3:02 pm

jlouvar wrote:PS: Were you able to recreate the problem, and if so, did you send the log file to Acoustica Support?

I'm still trying things out at this stage. I am trying an updated driver. Also, I believe I had a 32 bit plugin in the 64 bit vst folder, don't know if that did anything bad or not.

User avatar
jlouvar
Posts: 539
Joined: Wed Jul 24, 2013 4:56 pm
Location: California - USA

Re: Mixcraft not saving and freezing Please help

Postby jlouvar » Mon Mar 18, 2019 4:26 pm

Hmm, so you’re able to save okay and not having any more freezing problems now?
Mixcraft 8.1 Pro (64-Bit Build 418), Lenovo (1.80GHz, 8GB, 64-bit), Windows 10, Focusrite Scarlett 2i4, Event and PreSonus monitors, Korg TR61, Akai MPK249, MPK2 Mini, Fender American P & J basses, Strat, D35, and a lot of microphones, etc.

Benjamin Drew
Posts: 22
Joined: Sat Mar 16, 2019 3:14 am

Re: Mixcraft not saving and freezing Please help

Postby Benjamin Drew » Mon Mar 18, 2019 5:17 pm

jlouvar wrote:Hmm, so you’re able to save okay and not having any more freezing problems now?


Hope I'm not speaking too soon, but maybe the updated driver helped. I updated the Realtek driver then tried ASIO4ALL driver. Decided to stick with Core Audio wave rt. Funny thing is, mixcraft shows at the bottom I have a 20 ms latency which is not the case, there's no latency at all.

Just did a flawless mixing and everything appears to work as it should.

If all goes well, maybe it had to do with the updated driver and the fact that IO accidentally put a 32 bit plugin in the 64 bit VST location. I added a couple of photos.
Attachments
Capture1.PNG
Capture1.PNG (144.98 KiB) Viewed 98 times
Capture.PNG
Capture.PNG (52.45 KiB) Viewed 98 times

User avatar
Acoustica Greg
Posts: 18825
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: Mixcraft not saving and freezing Please help

Postby Acoustica Greg » Tue Mar 19, 2019 8:49 am

Hi,

A latency of 20.3 means there is a 20.3 millisecond delay in the time it takes for you to hear the audio. That's 20.3 thousandths of one second.

Greg
Mixcraft 8 - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

Benjamin Drew
Posts: 22
Joined: Sat Mar 16, 2019 3:14 am

Re: Mixcraft not saving and freezing Please help

Postby Benjamin Drew » Tue Mar 19, 2019 10:12 am

Acoustica Greg wrote:Hi,

A latency of 20.3 means there is a 20.3 millisecond delay in the time it takes for you to hear the audio. That's 20.3 thousandths of one second.

Greg


Yeah, I understand that. In the past when I had settings of this type of latency it was very noticeable. Unless Mixcraft reported the latency wrong in the first place.

Before now, once I started going past 6 Ms it got to be noticeable.

Now it's just fine even though the report is 20 Ms for some reason.

By the way, did you guys get a chance to look over the Log I sent?
Last edited by Benjamin Drew on Tue Mar 19, 2019 10:39 am, edited 1 time in total.


Return to “Mixcraft”

Who is online

Users browsing this forum: No registered users and 19 guests