SAFE VST plugins not loading

Use this topic to discuss VST and DirectX plugins for Mixcraft, Spin It Again or Beatcraft.

Moderators: Acoustica Chris, Acoustica Eric

Post Reply
Brockola
Posts: 2
Joined: Wed Feb 12, 2020 4:45 pm

SAFE VST plugins not loading

Post by Brockola » Wed Feb 12, 2020 5:12 pm

Maybe someone can advise me. I'm using Mixcraft 7, 64bit. I moved everything from a Compaq running Windows 7 w 4GB Ram to a Dell Windows 10 w 8GB. I had a bit of trouble with the Compaq getting Mixcraft to load The SAFE Plugins by Semantic Audio Labs due to something to do with the "Microsoft Visual C++..." not being up to date. The DAW actually informed of that. Once I went to Microsoft and updated the plugins loaded. But now with the new and improved situation and I've checked for Windows updates and all seems good, I can't seem to get the SAFE Plugins to load. I used them on several recordings in the old computer and when I try to load a recording file Mixcraft looks for it but of course can't find it. Any one have the same experience and/or have a possible solution? Much appreciated.

User avatar
Rolling Estonian
Posts: 1748
Joined: Sun Jan 11, 2015 9:42 am
Location: MD/DC

Re: SAFE VST plugins not loading

Post by Rolling Estonian » Thu Feb 13, 2020 10:10 am

Do these plugs have an install program? Most are just .dll files but some have entire programs that you need to install. Have you tried scanning for new plugins in settings? Also, a lot of times a simple reboot will do it too.

Not familiar with those plugs but checking the above usually does the trick.

M

Brockola
Posts: 2
Joined: Wed Feb 12, 2020 4:45 pm

Re: SAFE VST plugins not loading

Post by Brockola » Mon Feb 17, 2020 1:31 pm

No, no install program with these VSTs, just the .dll files. Yes, I did re-scan and Mixcraft finds the vst's .dll but under Manage Plug-ins, they fall under the "Unable to Load" Category which I have moved to the load position and reboot Mixcraft as instructed and still does not load.
Thanks for your input though.

User avatar
Acoustica Greg
Posts: 21640
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: SAFE VST plugins not loading

Post by Acoustica Greg » Mon Feb 17, 2020 1:40 pm

Hi,

Which ones are you trying to load, exactly?

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

User avatar
Acoustica Greg
Posts: 21640
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: SAFE VST plugins not loading

Post by Acoustica Greg » Mon Feb 17, 2020 1:46 pm

Hi,

Actually, I just downloaded and installed SAFECompressor, SAFEDistortion, etc. and they are all working just fine for me in Mixcraft 9.0 build 452.

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

Post Reply