Mixer Problem

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Chris, Acoustica Eric, Acoustica Dan, Acoustica Greg

Post Reply
Faith King
Posts: 4
Joined: Sat Dec 26, 2015 4:54 pm

Mixer Problem

Post by Faith King » Sat Dec 26, 2015 4:59 pm

I have a Behringer XENYX X1834 mixer. Acoustica doesn't recognize it. I need to use it for vocals. Has anyone any suggestions on how to get it to work? Would really appreciate it. I have Windows 10.
Thanks in advance
Faith King

User avatar
Acoustica Greg
Posts: 21249
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: Mixer Problem

Post by Acoustica Greg » Mon Dec 28, 2015 11:13 am

HI,

Does Windows recognize it? Does it show up as a recording device in Windows? Right-click on the small volume control icon in the Windows taskbar and select Recording Devices. You should be able to play audio on your mixer and see the level meters moving there.

Greg

Faith King
Posts: 4
Joined: Sat Dec 26, 2015 4:54 pm

Re: Mixer Problem

Post by Faith King » Mon Dec 28, 2015 1:21 pm

Thanks Greg, I'll check it out. I also found the original drivers for Behringer. A fluke, actually. These drivers are not available any longer on the Behringer site, so I had to hunt for them.
Ok, so I downloaded and installed them which showed up in Acoustica. However, when recording vocals, nothing happened.
By the way, if anyone needs these drivers let me know, and I'll happily provide them.
I originally bought the mixer to use for vocals. I'm thinking I might have to install WDM drivers,I'm not certain which one I need, so kind of leery of how to go about doing that. I also have ASIO4all installed. It looked like the WDM was included in the drivers I downloaded for the mixer. Very confused about what to do.
Thanks again Greg, for your advice.

Faith King
Posts: 4
Joined: Sat Dec 26, 2015 4:54 pm

Re: Mixer Problem

Post by Faith King » Mon Dec 28, 2015 1:31 pm

I just checked recording devices on my task bar, and the mixer was listed as: Behringer USB WDM Audio 2.8.40. I set it as default. Maybe setting it as default, might make a difference. I'll report back if it works.
Thanks

Faith King
Posts: 4
Joined: Sat Dec 26, 2015 4:54 pm

Re: Mixer Problem

Post by Faith King » Mon Dec 28, 2015 2:05 pm

It works now, thanks Greg!!

Post Reply