Trying to set up Zoom R24 as interface

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Dan, Acoustica Greg, Acoustica Chris, Acoustica Eric

mandofrog
Posts: 10
Joined: Sun Apr 24, 2011 3:46 pm
Location: Puerto Vallarta, MX

Trying to set up Zoom R24 as interface

Post by mandofrog » Thu Feb 25, 2016 10:41 am

Hi all,
Has anybody had success with using a Zoom R16 or R24 as an interface w/ MixCraft 7 PS? The Zoom R24 & R16 are multi-track recorders AND also DAW interface. The Zoom references show tips for setting up several other DAWs (Cubase, Logic, Sonar, etc.), but they don't mention MixCraft. Pro Tools 9 will not work w/ Zoom, because PT9 does not support "Mackie Control" mode, and Zoom uses ONLY Mackie Control mode.

So I thought it would be fine with MC, because MC seems to support Mackie Control. But NO! MC 7.7 PS (build 301) crashes and burns every time it tries to initiialize the R24. I've downloaded/installed all the latest firmware and drivers and there's no joy. I've tried CoreAudio (Wave RT) and ASIO, with the same result.

Windows 10 (64 bit, with all latest updates), HP notebook w/ i5 cpu & 4gb ram.

MixCraft 7 PS looks like a nice DAW, with several key improvements from the MC5 I was using before. Had great hopes to get this all working.

User avatar
fredfish
Posts: 1365
Joined: Sun May 23, 2010 12:57 pm
Location: Colchester, Essex, UK

Re: Trying to set up Zoom R24 as interface

Post by fredfish » Thu Feb 25, 2016 1:46 pm

Hi Mandofrog

I have a Zoom R24 and have it working fine with Mixcraft 7 - Now!
Last edited by fredfish on Thu Feb 25, 2016 1:56 pm, edited 2 times in total.

User avatar
fredfish
Posts: 1365
Joined: Sun May 23, 2010 12:57 pm
Location: Colchester, Essex, UK

Re: Trying to set up Zoom R24 as interface

Post by fredfish » Thu Feb 25, 2016 1:54 pm

Hi Mandofrog

I have a Zoom R24 and have it working fine with Mixcraft 7 - Now!

Like you I had big issues to start with - crashing, usually within about a minute of starting - usually leading to a Blue Screen. Using a utility called "WhoCrashed" it always reported that there was an issue with the Zoom Driver. I asked the question on the Zoom website and that proved less than helpful (not a single response). So I started tweaking.

For me what ended up working is changing the sample rate on the Zoom from 96k to 44k.

I have to do this immediately after launching the zoom ASIO driver within Mixcraft (do this in the sound preferences - when you select zoom as the ASIO device immediately change the sample rate to 44k - this will then be reflected on the Zooms display). Unfortunately there doesn't appear to be a way to get the Zoom to automatically default to 44k.

I can then select Mackie in the Control Surface settings and all is well.

That is what works for me - I hope you have success.

Cheers

John

GovernmentMule
Posts: 307
Joined: Thu Oct 30, 2014 3:58 pm

Re: Trying to set up Zoom R24 as interface

Post by GovernmentMule » Thu Feb 25, 2016 3:22 pm

Zoom R16 here. I set it up for 44.1 sample rate from day one and never have had even a slight hiccup out of mine. I would do what John has advised and see how that works.

mandofrog
Posts: 10
Joined: Sun Apr 24, 2011 3:46 pm
Location: Puerto Vallarta, MX

Re: Trying to set up Zoom R24 as interface

Post by mandofrog » Mon Feb 29, 2016 1:59 pm

Thanks for the tips. So far, partial success. I downloaded MC build 303, and that seems to be helping the system stability. Now the whole Win10 system is not seizing up when I configure MC7.

Just to make sure MC was behaving properly, I plugged in an M-Audio Fast Track Ultra interface & all works well. But I'd rather get the R24 working to use the multi-track recorder with the interface.

With the Zoom, under Sound Device, when I select Core Audio (Wave RT), I can select the Zoom R24 as Input and Output, but can't get any signal to register.

I understand ASIO is probably the better way to go for this. When I select the ASIO driver, the ASIO Device shows the Zoom R24, but Input and Output are blank - no devices to select. Sample Rate and Buffer Size are also blank. I ~would~ set the sample rate to 44.1k, but it won't let me select anything there. That kind of tells me that Zoom's ASIO driver may be a problem. If I try to arm a track, I just get a message that says no recording device can be found.

When I select the Wave driver, the signal registers and I can arm, record and playback multiple tracks. But latency is much higher, and wouldn't I lose some functionality using the Wave driver? Also with the Wave driver, when I select the Zoom as Input/Recording Device, I can select a sample rate of 44.1k, but the Zoom still displays 96k. That tells me that there is not complete communication.

So I'm still trying.

User avatar
Acoustica Greg
Posts: 20437
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: Trying to set up Zoom R24 as interface

Post by Acoustica Greg » Mon Feb 29, 2016 4:17 pm

Hi,

Are you using 64-bit Mixcraft? Try installing 32-bit Mixcraft and see if that gets ASIO working for you. You can have both 32- and 64-bit Mixcraft installed at the same time. The audio quality is the same.

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

mandofrog
Posts: 10
Joined: Sun Apr 24, 2011 3:46 pm
Location: Puerto Vallarta, MX

Re: Trying to set up Zoom R24 as interface

Post by mandofrog » Mon Feb 29, 2016 4:57 pm

So far just 32-bit MC. I've gone through several cycles of un-installing and re-installing both the Zoom driver and MC7. Each time with a reboot before the next step. (guessing I've reboot the system about 30+ times in the last few days).

I'm using the following steps (as per Zoom manual):
-power on Zoom R24
-activate Audio Interface mode (starts at 44.1 khz rate)
-plug R24 into PC with USB cable (R24 immediately changes to 96 khz rate)
-open Mixcraft

On closing:
-close Mixcraft
-deactivate Audio Interface mode on R24
-un plug R24

I'm running out of ideas.

User avatar
Acoustica Greg
Posts: 20437
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: Trying to set up Zoom R24 as interface

Post by Acoustica Greg » Mon Feb 29, 2016 5:02 pm

Hi,

Right-click on Mixcraft's icon and select Properties. Choose the Compatibility tab and try running Mixcraft in Windows 8 compatibility mode. Does that allow ASIO to work?

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

GovernmentMule
Posts: 307
Joined: Thu Oct 30, 2014 3:58 pm

Re: Trying to set up Zoom R24 as interface

Post by GovernmentMule » Mon Feb 29, 2016 5:29 pm

Hey Mandofrog, this is the way I power up each time. Power the Zoom up with the usb cable and hit enter three times until you see the sample rate screen. It should be at 44.1. Right click on the speaker icon in the task bar, I'm on windows 7 so it may be a little different if you are using another OS. After right clicking go to recording devices, a sound tab will come up. Under the recording tab your Zoom should be listed. Highlight it and another box will come up, hit the advanced tab and then properties tab and make sure under exclusive mode make sure the "Allow applications to take control of this device" is checked. The Zoom in USB Audio Interface mode follows the application sample rate. Then open mixcraft and see if that helps. It seems like some other application is taking control and changing the sample rate.

jddrock
Posts: 74
Joined: Sat Sep 14, 2013 6:43 pm

Re: Trying to set up Zoom R24 as interface

Post by jddrock » Mon Feb 29, 2016 7:23 pm

I had similar problems when I borrowed a friends Zoom R16 or 24. Is the Zoom screen switching sometimes quickly between two different sample rates, say 44.1 and 96? The one I was using did, and as GovernmentMule mentioned, it appeared some other application was trying to change the sample rate while Mixcraft was working to keep it at another sample rate. Then whenever would try to record with it, it would freeze up and I would have to restart either the zoom or MC or both. I'm having a little trouble remembering exactly what I did since I don't have the Zoom in my possession to test it with now, but I'm pretty sure my problem was resolved when I opened the hardware and sound options window in the control panel, opened the "Recording" tab under sound options, right clicked on the Zoom device in the list, selected "Properties", opened the "advanced" tab, and then I saw that the Zoom interface was set to a different recording sample rate than MC. That's what was causing the tug of war between two sample rates. MC's settings and my computers default sound settings for the Zoom recording device were fighting eachother.

mandofrog
Posts: 10
Joined: Sun Apr 24, 2011 3:46 pm
Location: Puerto Vallarta, MX

Re: Trying to set up Zoom R24 as interface

Post by mandofrog » Fri Mar 11, 2016 11:08 am

Thanks for the tips.

Greg, the icons on my Win10 Start menu don't have a Properties option; only "Pin to Start", "Pin to Taskbar", "Run as Administrator", "Open File Location", and "Remove from List". Same with the icon under All Apps (from Start menu). I never use icons on the desktop (I always delete them as soon as they're created by an installation), but on a fresh install I left the icon on the desktop and set the properties to Win8 compatibility mode. I left it on the desktop long enough to test a few ideas.

GovernmentMule, I followed your steps under "Recording Devices". Under both the Recording tab and Playback tab, the Zoom was set to 96kHz. Indeed, upon changing that to 44.1kHz I got a message saying another application was using the device (had not opened MixCraft yet), and that changing the setting would kill the other application. (Yes please!) Changing the Playback device to 44.1 changed the Zoom's display back to 44.1. "Allow applications to take exclusive control" was already checked on both Playback and Recording.

jddrock, no the Zoom's sample rate was not switching back and forth. When I power up the Zoom unconnected it shows 44.1kHz, but immediately upon connecting to the PC it changed to 96kHz and stayed. Gov'tMule's tip resolved that at least.

After those tweeks, I was able to get a signal from the Zoom to register on a track in MC7 - once. Then when I tried to repeat the whole process, MC7 started crashing again within a minute of starting. I checked the above tweeks to make sure they hadn't changed (they hadn't), and at least now it all stays at 44.1kHz. MC7 still runs perfectly with a different interface (M-Audio), but when I open it with the Zoom activated, MC7 still locks up within seconds and I have to use task manager to kill it so I can reboot the system. My strongest suspicion is either a faulty Zoom driver, or some other app is conflicting with the Zoom driver (not using any other audio app, but it's always possible something could be loading in the background).

So my executive decision is that a few dozen hours and about 15 or 20 reboot-uninstall-reboot-reinstall-reboot cycles are enough. I want to play music, not be a computer troubleshooter. The Zoom R24 may be headed for eBay. Thanks for the help and advice folks.
-Randy

J Gretch
Posts: 160
Joined: Fri Nov 02, 2007 11:39 am

Re: Trying to set up Zoom R24 as interface

Post by J Gretch » Tue Mar 15, 2016 7:31 am

hey mandofrog,
It may be wise to give it a few days and try again. I know what it's like to get frustrated with hardware problems when all you want to do is lay down some tracks and make music. FWIW I have been using a Zoom R16 with Mixcraft for years with no problems. It was Mixcraft 5 (32-bit) on an XP Pro machine at first, then Pro Studio 6 on a Win-7 (32-bit) machine, and now Pro Studio 7 on a Win-7 machine(64-bit) machine.

I always launch Mixcraft first then connect the R16 via usb. Then press the enter key on the R16 3 times till it displays the sample rate. At that point I get the pop up in Mixcraft letting me know that it sees another device. I hit OK and make sure my preferences are set to to ASIO Drivers in Mixcraft and that's it. Works for me every time.

Hope you can get your Zoom working, I absolutely love mine and it has held up well over the years.

DarrenBGreat
Posts: 2
Joined: Sat Jul 16, 2016 3:51 am

Re: Trying to set up Zoom R24 as interface

Post by DarrenBGreat » Sat Jul 16, 2016 4:01 am

Hi I'm a senior attempting to fulfill my lifelong desire to learn guitar and singing.
That said, please understand I'm a total newbie and don't have much studio-speak so that limits me in asking for what I require.
I have an old version of Mixcraft properly licensed and a Zoom R24.
What I'm looking for is protocols or tutorial video that clearly shows me how to take a given song, load it into a project and play it while also listening to myself play along with it.
I don't read music so have to learn by ear.
Any ideas?
Sincerely
DarrenB

DarrenBGreat
Posts: 2
Joined: Sat Jul 16, 2016 3:51 am

Re: Trying to set up Zoom R24 as interface

Post by DarrenBGreat » Sat Jul 16, 2016 4:04 am

I should add that I have successfully created a project with the song required, however every time I play it there is a loud disruptive sincopated metronome-like sound like static.

User avatar
Rolling Estonian
Posts: 1407
Joined: Sun Jan 11, 2015 9:42 am
Location: MD/DC

Re: Trying to set up Zoom R24 as interface

Post by Rolling Estonian » Sat Jul 16, 2016 1:48 pm

Hey Darren,

Welcome to the forum. You say you've got an old version of MC, which version? You really should update to MC 7, for the money, it's totally worth it. I have a feeling if you upgraded you'd have more stability.

As for playing a song Mp3/WAV, just drop and drag it into a project, or open from file menu.

The 'static' could be a number of things, is the metronome set to off?

M

Post Reply