No sound from keyboard

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Chris, Acoustica Eric, Acoustica Dan, Acoustica Greg

P Love
Posts: 48
Joined: Fri Mar 27, 2009 2:42 pm

No sound from keyboard

Post by P Love » Sun Dec 04, 2016 11:59 am

Hello,

I am having trouble getting my m-audio keystation 88es to produce sound with midi channels.
Eric suggested I Arm the midi track with "all midi channels".
This unfortunately didn't work. Still no sound from midi VSTs.
Any more suggestions?

Thank you all for your time and wonderful support.

GrizzKarizz
Posts: 124
Joined: Fri Dec 25, 2009 8:28 pm
Location: Sendai, Japan
Contact:

Re: No sound from keyboard

Post by GrizzKarizz » Sun Dec 04, 2016 7:59 pm

Just checking, but do you have your midi 'in' in your midi 'in'? You need to have the midi 'in' in the midi 'out'.

User avatar
Mark Bliss
Posts: 7098
Joined: Fri Jan 20, 2012 3:59 pm
Location: Out there

Re: No sound from keyboard

Post by Mark Bliss » Sun Dec 04, 2016 9:05 pm

It's a USB device right?
Does it show up as recognized by Windows device manager?

There has been some history of driver issues with M-Audio devices. First thing, need to know if a signal is getting to your computer.
Stay in tune, Mark

My SOUNDCLOUD Page

P Love
Posts: 48
Joined: Fri Mar 27, 2009 2:42 pm

Re: No sound from keyboard

Post by P Love » Mon Dec 05, 2016 11:47 am

Thank you both.
It is a USB MIDI keyboard.
I checked the device manager and it does show up there.

User avatar
Acoustica Greg
Posts: 21798
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: No sound from keyboard

Post by Acoustica Greg » Mon Dec 05, 2016 12:01 pm

Hi,

Which virtual instrument do you have selected? Arm a track and make sure you have piano or something selected on it. If you press record and play your keyboard, then stop the recording, does the clip disappear?

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

mick
Posts: 1499
Joined: Thu Dec 06, 2012 10:33 am

Re: No sound from keyboard

Post by mick » Mon Dec 05, 2016 12:17 pm

Some silly things to check...
Reset the keyboard to + - 0 octave to make sure you are not transmitting midi on an octave outside the range of the instrument.
Check the keyboard is not on demo mode if it has one.
Check the Mixcraft master volume control hasn't been accidentally put to zero.
Check the usb cable connection at both ends.
Try the musical typing keyboard to see if the vst itself is sounding. crtl +alt +k.

P Love
Posts: 48
Joined: Fri Mar 27, 2009 2:42 pm

Re: No sound from keyboard

Post by P Love » Mon Dec 05, 2016 2:32 pm

https://www.youtube.com/watch?v=ReBsFTy ... e=youtu.be

The cllip does disappear. No MIDI data is written from the keyboard.

Thank you all!

User avatar
Acoustica Greg
Posts: 21798
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: No sound from keyboard

Post by Acoustica Greg » Mon Dec 05, 2016 3:17 pm

Hi,

I'll reply to your support ticket.

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

P Love
Posts: 48
Joined: Fri Mar 27, 2009 2:42 pm

Re: No sound from keyboard

Post by P Love » Mon Dec 05, 2016 6:48 pm

https://www.youtube.com/watch?v=EiV2Syo ... e=youtu.be

Hi again,

Tried out MIDI Ox as recommended.
I just get this error message and can't even test it properly.
I don't understand what's wrong... Gah!

Thank you everyone for contributing!

User avatar
Ajgi
Posts: 66
Joined: Sat Aug 23, 2014 5:19 am
Location: Auckrand, New Zealand
Contact:

Re: No sound from keyboard

Post by Ajgi » Mon Dec 05, 2016 10:47 pm

I had trouble connecting any midi to Mixcraft a few years ago when I got my first keyboard. Nothing would work, eventually I just reformatted my computer, and never had any other problems :?
Ajgi.net
SoundCloud
Focusrite Scarlett 2i2, Wharfedale Diamond 8.2 Studio Monitors, Sennheiser HD280pro, Shure SM57,

P Love
Posts: 48
Joined: Fri Mar 27, 2009 2:42 pm

Re: No sound from keyboard

Post by P Love » Tue Dec 06, 2016 9:36 am

I am using Windows 10 with Mixcraft Pro Studio 6 so maybe that is the problem?
Maybe if I upgrade to Mixcraft 7 or 8 they would be compatible with the drivers?

James Klutho
Posts: 29
Joined: Thu Sep 04, 2014 6:35 am

Re: No sound from keyboard

Post by James Klutho » Tue Dec 06, 2016 9:59 am

I have a 49es which I don't use anymore but I remember having to download the driver from the "legacy" area at the m-audio website a few years ago. My guess your controller is obselete from a Windows 10 perspective. Do you have a Windows 7 laptop or something to try your controller on? The ES series has been replaced with the KEYSTATION series which does not require loading a driver on Windows.

Jim

User avatar
Mark Bliss
Posts: 7098
Joined: Fri Jan 20, 2012 3:59 pm
Location: Out there

Re: No sound from keyboard

Post by Mark Bliss » Tue Dec 06, 2016 10:22 am

P Love wrote:I am using Windows 10 with Mixcraft Pro Studio 6 so maybe that is the problem?
Maybe if I upgrade to Mixcraft 7 or 8 they would be compatible with the drivers?

No, this doesn't appear to be a Mixcraft issue. I am thinking Windows isn't recognizing the controller.

Again:
Mark Bliss wrote:Does it show up as recognized by Windows device manager?

There has been some history of driver issues with M-Audio devices. First thing, need to know if a signal is getting to your computer.
James Klutho wrote:My guess your controller is obselete from a Windows 10 perspective.
Based on the number of driver issues I have read about for M-Audio controllers and interfaces, this would be my guess as well.
Example, this thread about Win7 issues on M-Audio's own site:
http://community.m-audio.com/m-audio/to ... _wont_work

Company ownership has changed several times in a relatively short period, and I have seen a lot of discussion about problems with drivers, legacy support and older models, etc.
Stay in tune, Mark

My SOUNDCLOUD Page

User avatar
Acoustica Greg
Posts: 21798
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: No sound from keyboard

Post by Acoustica Greg » Tue Dec 06, 2016 10:57 am

P Love wrote:https://www.youtube.com/watch?v=EiV2Syo ... e=youtu.be

Hi again,

Tried out MIDI Ox as recommended.
I just get this error message and can't even test it properly.
I don't understand what's wrong... Gah!

Thank you everyone for contributing!
Hi,

I think you're getting that error because of a MIDI loop. Choose your keyboard as the input and the output and make sure Mixcraft isn't running when you try it.

Greg

P.S. Also make sure you're not running MIDI Ox when you're trying to pick up MIDI in Mixcraft.
MIDI Ox settings and status screens.
MIDI Ox settings and status screens.
MIDIox.png (143.57 KiB) Viewed 4684 times
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

mick
Posts: 1499
Joined: Thu Dec 06, 2012 10:33 am

Re: No sound from keyboard

Post by mick » Tue Dec 06, 2016 11:09 am

Try this because I have a 25 key M-audio kb and the drivers do not work but windows plug and play picks it up and it works fine.
Delete the M-audio drivers completely then hit "midi reset" (I think its in the mix dropdown list but not sure) close and re-open Mixcraft.
Last edited by mick on Tue Dec 06, 2016 2:17 pm, edited 1 time in total.

Post Reply