M-Audio Fast Track Pro won't work with USB 3 [SOLVED}

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Dan, Acoustica Greg, Acoustica Chris, Acoustica Eric

User avatar
outteh
Posts: 3458
Joined: Wed Dec 12, 2012 12:23 pm
Location: San Antonio, TX

Re: M-Audio Fast Track Pro won't work with USB 3

Post by outteh » Fri Dec 23, 2016 1:31 pm

It could be a cabling issue also: Although this is not a software solution, if you use a USB 2 extension cable then it will prevent the 5 USB 3 pins in the plug from physically connecting the wires which carry the USB 3 handshake between the host and device. A USB 2 device or cable only has 4 pins. A USB 3 port will default to USB 2 signaling communication when only 4 pins are connected. A USB 2 extension cable only caries 4 wires that connect the 4 pins of USB 2 only communications.

They also make hubs and cable adapters that might help, you can google for results.

Led-ear
Posts: 27
Joined: Sat Dec 25, 2010 12:35 pm
Location: Bothell WA

Re: M-Audio Fast Track Pro won't work with USB 3

Post by Led-ear » Fri Dec 23, 2016 1:43 pm

My USB 3 jacks on my laptop have 4 pins, not 5.

User avatar
outteh
Posts: 3458
Joined: Wed Dec 12, 2012 12:23 pm
Location: San Antonio, TX

Re: M-Audio Fast Track Pro won't work with USB 3

Post by outteh » Fri Dec 23, 2016 1:58 pm

The ports should look like this
image.jpeg
image.jpeg (48.88 KiB) Viewed 10571 times

Led-ear
Posts: 27
Joined: Sat Dec 25, 2010 12:35 pm
Location: Bothell WA

Re: M-Audio Fast Track Pro won't work with USB 3

Post by Led-ear » Fri Dec 23, 2016 2:23 pm

You are correct, there are five pins. When I attempted earlier to install the latest Fast Track Pro driver 6.0.7 from my computer files it downloaded Microsoft driver instead. I finally manually loaded the file and my system appears to be functioning now. The glitch was mostly my own and I apologize for taking up so much of your time. I have seen others that have had this problem too and I hope this helps them as well.

User avatar
Mark Bliss
Posts: 6552
Joined: Fri Jan 20, 2012 3:59 pm
Location: Out there

Re: M-Audio Fast Track Pro won't work with USB 3

Post by Mark Bliss » Fri Dec 23, 2016 2:46 pm

No worries, its the outcome that matters, and this is good news.
Now go make some noise! 8)
Stay in tune, Mark

Image

My SOUNDCLOUD Page

GrizzKarizz
Posts: 124
Joined: Fri Dec 25, 2009 8:28 pm
Location: Sendai, Japan
Contact:

Re: M-Audio Fast Track Pro won't work with USB 3

Post by GrizzKarizz » Sun Dec 25, 2016 7:49 pm

I use the Roland Tri-Capture. It works with USB-3. It's also very inexpensive.

User avatar
Acoustica Greg
Posts: 19833
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: M-Audio Fast Track Pro won't work with USB 3

Post by Acoustica Greg » Mon Dec 26, 2016 12:14 pm

GrizzKarizz wrote:I use the Roland Tri-Capture. It works with USB-3. It's also very inexpensive.
Hi,

If you read a couple posts back, you'll see that Led-ear fixed the problem by installing the correct drivers.

In most cases, USB 3.0 ports should be able to handle USB 2.0 devices. Having the correct audio drivers from the manufacturer installed is key.

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

Post Reply