EWQL Play 6

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Chris, Acoustica Eric, Acoustica Dan, Acoustica Greg

Post Reply
Savannahrenovations
Posts: 17
Joined: Sun Oct 29, 2017 11:17 am

EWQL Play 6

Post by Savannahrenovations » Sun Feb 04, 2018 10:53 am

Is anyone using Play 6 in Mixcraft? Any known issues?

I had read in the forums in the past of someone having an issue with 5 and being advised to downgrade (to 4.3.5?) and that worked for that poster. This prompted me to submit a ticket to Acoustica as the downgrade would remove many options in the EWQL library...the response was that they were using Play 5 successfully.

With that, I am totally cool with using PLAY 5, I just know I will be prompted to download PLAY 6 once I pull the trigger and was wondering if anyone had any insight.

Thanks!!!!!

User avatar
chibear
Posts: 1861
Joined: Sun Sep 04, 2011 7:25 am
Location: Manitoba, Canada

Re: EWQL Play 6

Post by chibear » Sun Feb 04, 2018 11:23 am

I suggest before doing any upgrades to Play you check the soundsonline forums and see who is having problems and with what. Some of the issues are Mac only, some PC only. Personally, I have no desire to use Composers Cloud or Hollywood Choirs, so am happy to stay on Play 4.xx
Win 7 Pro, 3930K, Gigabyte Ga-X79-UP4, Corsair AX860i, 64GB gSkill 1600 RAM, 5 X 120 GB Intel 520 SSD, 1T & 2T WD caviar black, EVGA nVidea 560, Asus Xonar Essence STX EWQL CCC, Kirk Hunter, Chris Hein, Omnisphere
Soundcloud YouTube

Savannahrenovations
Posts: 17
Joined: Sun Oct 29, 2017 11:17 am

Re: EWQL Play 6

Post by Savannahrenovations » Sun Feb 04, 2018 11:50 am

I totally understand where you are coming from, chibear. I am going to use the composer cloud subscription to "test drive" the products, then purchase as they go on sale (and as I can afford).

I have done some reading already and yes, there are some users who are having issues with 6. I probably would not go with 6 just for those reasons...unless someone here was using it with success. 6 is only needed for Hollywood Choirs, so no big deal there.

Looks like downgrading to version 4.x.x would lock me out of 9 of the current products listed on the main products page. I just bought a new computer that should be able to handle just about anything out there and am excited to test it all out. Just hate the idea of being bogged down for days and days trying to get a product to work with no success...that's the worst!

User avatar
Acoustica Greg
Posts: 21122
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: EWQL Play 6

Post by Acoustica Greg » Mon Feb 05, 2018 10:53 am

Hi,

When you see people posting about problems on forums, you always have to take it with a grain of salt. Only the people who have problems tend to post, so you really should try to gauge whether the problems people are having are ones that would impact you, or more obscure technical issues that most people wouldn't run into.

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

Savannahrenovations
Posts: 17
Joined: Sun Oct 29, 2017 11:17 am

Re: EWQL Play 6

Post by Savannahrenovations » Wed Feb 07, 2018 7:31 am

Greg...thanks for taking the time to reply. I was just trying to avoid any issues in advance.

I went ahead and pulled the trigger on the Composer Cloud subscription. As expected it automatically wanted to install PLAY 6. I fretted for a moment...and pushed install. The results after a few hours of tinkering:

95-98% of everything works flawlessly!

Only issue I am having is with Choirs, both Hollywood and Symphonic. Still usable...just got some glitches. I have not spent a great deal of time with any of it yet, but could be user error. I am going to work with is for a while and see if I can resolve on my own.

Post Reply