Phew - we're back, and we updated the forum software

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Chris, Acoustica Eric, Acoustica Dan, Acoustica Greg

User avatar
Ian Craig
Posts: 886
Joined: Sun Jan 22, 2017 7:15 pm
Location: Belfast, Northern Ireland, UK
Contact:

Re: Phew - we're back, and we updated the forum software

Post by Ian Craig » Tue Dec 03, 2019 9:08 pm

Anorax wrote:
Tue Dec 03, 2019 9:03 pm
did your quick-load button usually take you to a page that said "redirecting to the forums, please wait"?
No, it just loads straight away
Mixcraft 9 Pro Studio Beta Testing Build 453 (64bit)
AMD Ryzen 8 Core 3.0 GHz,
2TB SSD etc, 40GB RAM,
Windows 10 Professional
Behringer UMC22 (Audio Interface)

User avatar
Thomas
Posts: 349
Joined: Thu May 24, 2018 2:54 pm

Re: Phew - we're back, and we updated the forum software

Post by Thomas » Tue Dec 03, 2019 11:34 pm

My old link still works- https://forums.acoustica.com/bbs/index.php

The web chatter is that it was a DDOS attack. The big guys are shakin' in their boots after seeing Mixcraft 9 in action. :lol:
-Tom
Mixcraft 8 Pro Studio 64-Bit
Windows 10 64-Bit
AMD Athlon II X4 645 3.1 GHz 10GB Ram 7200RPM? HDD
Behringer UMC404HD v4.59 interface

Glaw
Posts: 99
Joined: Mon Apr 18, 2011 8:19 pm

Re: Phew - we're back, and we updated the forum software

Post by Glaw » Wed Dec 04, 2019 12:26 am

I really wanted to upgrade my Mixcraft Pro Studio 8 to Pro Studio 9 while on sale, but I couldn't because of this problem. Did I lose my chance?
:(

User avatar
trevlyns
Posts: 2498
Joined: Sun May 06, 2012 1:59 am
Location: Wiltshire, UK
Contact:

Re: Phew - we're back, and we updated the forum software

Post by trevlyns » Wed Dec 04, 2019 12:52 am

70-563-1--1524847036.jpg
70-563-1--1524847036.jpg (80.7 KiB) Viewed 151 times
Keep on trackin'

Trevor

Website
Soundcloud
FaceBook

Official OFC™ Founding Member

Win 10 64 bit; MX8 Pro; Intel quad core i-5; 3.0 GHz; 16 GB RAM
I started out with nothing - and still have most of it left! - Seasick Steve

User avatar
Thomas
Posts: 349
Joined: Thu May 24, 2018 2:54 pm

Re: Phew - we're back, and we updated the forum software

Post by Thomas » Wed Dec 04, 2019 10:00 am

Glaw wrote:
Wed Dec 04, 2019 12:26 am
I really wanted to upgrade my Mixcraft Pro Studio 8 to Pro Studio 9 while on sale, but I couldn't because of this problem. Did I lose my chance?
:(
It appears that the upgrade offer extends through December 6th.
https://acoustica.com/mixcraft/upgrades
-Tom
Mixcraft 8 Pro Studio 64-Bit
Windows 10 64-Bit
AMD Athlon II X4 645 3.1 GHz 10GB Ram 7200RPM? HDD
Behringer UMC404HD v4.59 interface

User avatar
Acoustica Greg
Posts: 20669
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: Phew - we're back, and we updated the forum software

Post by Acoustica Greg » Wed Dec 04, 2019 10:38 am

Mark Bliss wrote:
Tue Dec 03, 2019 6:55 pm
So whats the story on the "updated forum"?
So far I only detect a new "face". Any function changes?
Hi,

I don't have a list of the new bells and whistles, but the main thing is just that the version we were using was way out of date, and this version includes a lot of security and bug fixes.

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

Post Reply