How to get my audio interface to work in mix craft?

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Chris, Acoustica Eric, Acoustica Dan, Acoustica Greg

Musicalmistress
Posts: 13
Joined: Sun Dec 08, 2019 9:08 am

How to get my audio interface to work in mix craft?

Post by Musicalmistress » Sun Dec 08, 2019 9:11 am

I have Mixcarft 8 recording studio and my audio interface is the Behringer U-phoria. I'm trying to record guitar. I saw a similar post on here before and someone had said to click Preferances and then click Sound Device and ASIO but I'm unable to click ASIO, I can only click Core Audio or Wave.

I'm also confused about how the program picks up the interface - will it pick it up as if it's as mic (it seems to be doing that but there's no sound), or will it be registered as one of the instruments?

I'm really confused and not very good at tech, just want to get recording. Would appreciate any insight.

User avatar
jlouvar
Posts: 1684
Joined: Wed Jul 24, 2013 4:56 pm
Location: California - USA
Contact:

Re: How to get my audio interface to work in mix craft?

Post by jlouvar » Sun Dec 08, 2019 9:25 am

Musicalmistress wrote:
Sun Dec 08, 2019 9:11 am
I have Mixcarft 8 recording studio and my audio interface is the Behringer U-phoria. I'm trying to record guitar. I saw a similar post on here before and someone had said to click Preferances and then click Sound Device and ASIO but I'm unable to click ASIO, I can only click Core Audio or Wave.

I'm also confused about how the program picks up the interface - will it pick it up as if it's as mic (it seems to be doing that but there's no sound), or will it be registered as one of the instruments?

I'm really confused and not very good at tech, just want to get recording. Would appreciate any insight.
Hello and welcome to the mixcraft forum.

Go to the Behringer website and download/install the most recent drivers for your audio interface. Plug the audio interface into your PC using the USB cable. Then you should be able to select ASIO in Mixcraft preferences and setup your audio interface. It should look something like this image but for your Behringer audio interface instead of for my Focusrite Scarlett 2i4 interface.
Attachments
101a.PNG
101a.PNG (157.66 KiB) Viewed 1318 times
Last edited by jlouvar on Sun Dec 08, 2019 2:42 pm, edited 2 times in total.
- Joe -
MX 9.0 Pro, Build 460, 64-bit. Windows 10. i5, 1.80GHz, 8GB.
Reverbnation: https://www.reverbnation.com/joelouvar

GovernmentMule
Posts: 332
Joined: Thu Oct 30, 2014 3:58 pm

Re: How to get my audio interface to work in mix craft?

Post by GovernmentMule » Sun Dec 08, 2019 9:37 am

After making sure your drivers are installed like jlouvar said, make sure you have the behringer selected in the preferences for the Default Recording device and Playback Device. Page 320 in the manual.

Hopefully the ASIO choice will be available and then open an audio track and the select the Behringer and channel by using the dropdown menu next to the ARM button on the audio track. Page 114 and 115 in the manual.

User avatar
Acoustica Greg
Posts: 21000
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: How to get my audio interface to work in mix craft?

Post by Acoustica Greg » Sun Dec 08, 2019 12:45 pm

Hi,

As mentioned, if you don't see an ASIO option with the Behringer connected, and that model does support ASIO, you need to go to Behringer's web page to download the latest driver: https://www.behringer.com/Categories/c/ ... ans(en|en)

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

Musicalmistress
Posts: 13
Joined: Sun Dec 08, 2019 9:08 am

Re: How to get my audio interface to work in mix craft?

Post by Musicalmistress » Mon Dec 09, 2019 11:28 am

I have downloaded the driver and installed it but it doesn't seem to recognise my audio interface and says "no devices connected" even though my computer is registering it fine. Not sure what the issue is and I still can't click Asio

User avatar
Acoustica Greg
Posts: 21000
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: How to get my audio interface to work in mix craft?

Post by Acoustica Greg » Mon Dec 09, 2019 11:44 am

Hi,

Make sure your audio interface is properly connected to your computer. When you go into Mixcraft's Sound Device preferences, also make sure that you've got the correct setting in the ASIO Device setting.
ASIO Device setting
ASIO Device setting
ASIODevice_setting.png (23.14 KiB) Viewed 1267 times
Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

Anorax
Posts: 1081
Joined: Mon Jul 18, 2011 7:58 pm

Re: How to get my audio interface to work in mix craft?

Post by Anorax » Tue Dec 10, 2019 6:13 pm

One thing I've noticed with Music Tribe devices (Behringer, Midas, Klark Teknik, etc) is that you need to double check that the device is showing up in Windows and that the driver is actually showing up for the device. You will want to check this using the Device Manager in Windows. If you're on Windows 10, you should be able to simply search for Device Manager.
2019-12-10.png
2019-12-10.png (35.12 KiB) Viewed 1218 times
Windows 7 and 8 should have the Device Manger under the Administrator Tools of the app list in your start menu.

Once the manager opens, try to find your U-phoria under the Sound, Video and Game Controllers list.
2019-12-10 (1).png
2019-12-10 (1).png (88.89 KiB) Viewed 1218 times
If it's not here, check for it under an "unknown device" section. If it shows up in that list, then you need to let Windows know what driver is correct - every once in a while Windows may have the right driver installed but doesn't know that it's supposed to be the right driver for a certain device.

If your U-Phoria is showing up, make sure that Behringer is listed as the driver manufacturer. If the device says Microsoft is the manufacturer instead, then you'll need to update the U-Phoria's driver, same as if the device shows up as "unknown device".

JonInc
Posts: 487
Joined: Sat Dec 05, 2009 2:30 pm
Location: East of Santa Monica

Re: How to get my audio interface to work in mix craft?

Post by JonInc » Wed Dec 11, 2019 10:13 am

If there are manufacturer-provided drivers for the device and you connected the device BEFORE installing driver package, that can mess things up to where it won't work even if you install the drivers after the fact.

If that is the case, best to uninstall the device drivers, reboot, then start over: First, make sure the device is NOT physically connected to your PC, then follow the Quick-start instructions that came with the device. Usually you're instructed to install the latest driver package, possibly a reboot is required (maybe not), and only then do you physically connect the device. Allow time for the device to be fully recognized.

From there you should be good to go....

Musicalmistress
Posts: 13
Joined: Sun Dec 08, 2019 9:08 am

Re: How to get my audio interface to work in mix craft?

Post by Musicalmistress » Mon Dec 16, 2019 12:18 pm

Hi all,

Thanks for your help so far - however I'm still stuck x-(

I uninstalled the driver as suggested, rebooted and then reinstalled it before connecting the device but now I'm just getting this in Mixcraft:

OK, I did a screenshot but I don't even know how to upload it! (You can tell I'm hopeless with technology!)

Basically the driver is showing up as the ASIO device instead of the actual device, so it's reading: 'ASIO4ALL v2' instead of the Behringer device (which is being registered by the computer as 'USB Audio CODEC' - don't know if that's part of the problem.

Also, when I try to update the driver via the Device Manager it just says "the best drivers for your device are already installed"

Any help would be greatly appreciated as it's becoming quite frustrating at this point!

Many thanks in advance.
Attachments
Screenshot (1).png
Screenshot (1).png (196.88 KiB) Viewed 1045 times

Musicalmistress
Posts: 13
Joined: Sun Dec 08, 2019 9:08 am

Re: How to get my audio interface to work in mix craft?

Post by Musicalmistress » Mon Dec 16, 2019 12:19 pm

Ah, the screenshot showed up after all!

User avatar
Acoustica Greg
Posts: 21000
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: How to get my audio interface to work in mix craft?

Post by Acoustica Greg » Mon Dec 16, 2019 12:32 pm

Hi,

Maybe you didn't download the correct driver from Behringer?

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

User avatar
jlouvar
Posts: 1684
Joined: Wed Jul 24, 2013 4:56 pm
Location: California - USA
Contact:

Re: How to get my audio interface to work in mix craft?

Post by jlouvar » Mon Dec 16, 2019 2:07 pm

Acoustica Greg wrote:
Mon Dec 16, 2019 12:32 pm
Hi,

Maybe you didn't download the correct driver from Behringer?

Greg
Unfortunately, I "think" many Behringer audio interfaces use ASIO4ALL?
Are the OP's ASIO Input and Output settings correct?
- Joe -
MX 9.0 Pro, Build 460, 64-bit. Windows 10. i5, 1.80GHz, 8GB.
Reverbnation: https://www.reverbnation.com/joelouvar

Musicalmistress
Posts: 13
Joined: Sun Dec 08, 2019 9:08 am

Re: How to get my audio interface to work in mix craft?

Post by Musicalmistress » Mon Dec 16, 2019 2:34 pm

Acoustica Greg wrote:
Mon Dec 16, 2019 12:32 pm
Hi,

Maybe you didn't download the correct driver from Behringer?

Greg
Hi,

I'm pretty sure it was the right one. I selected the driver for UMC22 which is what I have and there was only one option...

Musicalmistress
Posts: 13
Joined: Sun Dec 08, 2019 9:08 am

Re: How to get my audio interface to work in mix craft?

Post by Musicalmistress » Mon Dec 16, 2019 2:38 pm

I downloaded the top one from the list on the screenshot.
Attachments
Screenshot (2).png
Screenshot (2).png (128.98 KiB) Viewed 1021 times

User avatar
Acoustica Greg
Posts: 21000
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: How to get my audio interface to work in mix craft?

Post by Acoustica Greg » Mon Dec 16, 2019 2:45 pm

Hi,

Oh, I see that the UMC22 does use ASIO4All. I have a UMC204HD, and that has its own ASIO driver.

In that case, go into Mixcraft's sound device preferences, make sure you're in ASIO mode, then click Open Mixer. Make sure that the Behringer is the selected device. I think you just have to click on it to select it.

Greg
Mixcraft - The Musician's DAW
Give it a try here: http://acoustica.com/mixcraft/
Check out our Mixcraft University video tutorials.

Post Reply