Tempo change on imported .wav file

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Chris, Acoustica Eric, Acoustica Dan, Acoustica Greg

User avatar
tomsank
Posts: 7
Joined: Fri Jan 29, 2021 8:19 pm

Tempo change on imported .wav file

Post by tomsank » Fri Jan 29, 2021 8:28 pm

I mixed down some drum tracks to a .wav file to save some cpu usage, but when I try to add the track to my project, it plays back at a crazy speed. These are literally the same drum tracks from this same project, I have just mixed them together. When i play the .wav file from its saved location it is normal but when I create a new audio track in the project and drop the file in the empty track, the tempo has nothing to do with the song. There must be something I am missing. I am obviously a newby to Mixcraft (love it, BTW), but this is something that should be straightforward and I just don't get it. Any suggestions? I have looked on the boards for the same problem, and have not really found the exact issue, so it must be me. Again, sample rate, origination bpm, everything should be the same as this stereo .wav track is simply a mixdown of a bunch of pre-existing drums on the track. Help?

User avatar
tomsank
Posts: 7
Joined: Fri Jan 29, 2021 8:19 pm

Help.please!: Tempo change on imported .wav file

Post by tomsank » Fri Jan 29, 2021 10:40 pm

So I tried creating a new project with my drum mixdown, importing the wav file into an empty project and allowed Mixcraft to automatically adjust to the tempo that it was reading the file at - although the original was recorded at 138bpm, the program adjusted to 86.27bpm and the file played correctly(?!?) for whatever reason. Accepting this, I then followed the same process of mixing out a horn section, a rhythm guitar, and a mixdown of some guitar tapestry/textural type thing. I figured that all I would have to do would be to drop them into the new project with the drum mixdown and everything would be just dandy. After importing these three new tracks into the new project, I went to play back the result, only to find that every single track was playing back at a different tempo. I am definitely missing something. I have never worked with a DAW that arbitrarily changed the tempo of an audio track that was imported into a project. All four of these tracks play normally if I listen to them as wav files on any audio player that I have on my computer, from iTunes to Groove to RealPlayer to WMP to Winamp... why, then does it change when I drop it into an open Audio Track in Mixcraft? Please tell me what I am doing wrong; as this really hampers the workflow that I have been using for years of multi-tracking. Help?

User avatar
Mark Bliss
Posts: 7151
Joined: Fri Jan 20, 2012 3:59 pm
Location: Out there

Re: Tempo change on imported .wav file

Post by Mark Bliss » Fri Jan 29, 2021 11:32 pm

I have never had such problems, but it seems some people have some beat-matching or similar settings on that cause these kinds of problems.
Its likely a simple setting issue. I just cant tell you which, based on your info.
Stay in tune, Mark

My SOUNDCLOUD Page

User avatar
tomsank
Posts: 7
Joined: Fri Jan 29, 2021 8:19 pm

Re: Tempo change on imported .wav file

Post by tomsank » Sat Jan 30, 2021 12:50 am

Thanks Mark, I'll let you know if I find out anything.

User avatar
Rolling Estonian
Posts: 1807
Joined: Sun Jan 11, 2015 9:42 am
Location: MD/DC

Re: Tempo change on imported .wav file

Post by Rolling Estonian » Sat Jan 30, 2021 7:10 am


bigaquarium
Posts: 564
Joined: Thu Nov 16, 2017 3:21 am

Re: Tempo change on imported .wav file

Post by bigaquarium » Sat Jan 30, 2021 8:28 am

Morning,

I'm not by my computer right now but there are two buttons in the panel to the left of your sound tab "use project tempo" and "time stretch". Try changing those settings.

Nathan
youtube.com/c/fansofmixcraft
soundcloud.com/fansofmixcraft

User avatar
Mark Bliss
Posts: 7151
Joined: Fri Jan 20, 2012 3:59 pm
Location: Out there

Re: Tempo change on imported .wav file

Post by Mark Bliss » Sat Jan 30, 2021 9:49 am

Yeah, like Nathan I wasn't at my computer. Also tired and bleary eyed. 8)

I think the first thing to try, as Nathan suggests, making sure time stretch rate is set to 100% etc. as shown:

Sound tab settings.png
Sound tab settings.png (22.26 KiB) Viewed 1580 times
Stay in tune, Mark

My SOUNDCLOUD Page

User avatar
tomsank
Posts: 7
Joined: Fri Jan 29, 2021 8:19 pm

Re: Tempo change on imported .wav file

Post by tomsank » Sat Jan 30, 2021 5:00 pm

Thanks, guys.

@Rolling Estonian - unfortunately, this doesn't really apply. It plays back normally in an empty project, it is just when I load it back into the project that it came from that it is out of sync, because for whatever reason it is registering as a completely different tempo, as I said, from a project tempo of 138BPM, it is now showing as 86.27BPM so when it lays back at 138 it is wildly out of whack. Windows Audio Enhancements are disabled, so it is not that. I don't see why the sample rate would not be the same for the mixed down file as for the project that it is coming from,, but I can't find the "Edit Details / Specifiy Settings when you go to mix down" to verify. That could possibly be something to try, if you can tell me those settings are.

@Mark - Yes, the time stretch is set to 100% and I clicked on "Use Project tempo".

@Nathan - when you say try changing those settings, any suggestions as to what to change them to, or why? Otherwise, i am just randomly changing percentages and tempo without knowing why or what I am trying to accomplish.

The only thing that might be a thing is, from RE's link, the sample rate of the mixed down file is different from the sample rate of the project for some reason, and I don't understand where that setting is in order to check. I also don't understand why it would play back normally on a media player and in an empty project(albeit pretending to be a different tempo).

For now, I am just exporting audio tracks, tossing them over to my Mac and mixing on that, as a workaround, but it would be nice to be able to figure this out for future reference.

Also, I mentioned that I had exported other files and mix downs from. the same project to try to incorporate them all into a same new project, on the assumption that they would all be affected the same way, but I have
1) Rhythm guitar alone 138B.8PM (so pratically the original Project tempo of 138)
2) Mixdown of background guitars, textural stuff 69.1BPM (so more or less half the speed of the original tempo)
3)Mixdown of programmed horn arrangements 122.4BPM
and then
4) the drum mixdown that started all of this at 86.27BPM

I treated all of these exactly the same way File-Mix Down To-wav

MikeDVI
Posts: 180
Joined: Thu Oct 17, 2013 1:23 pm

Re: Tempo change on imported .wav file

Post by MikeDVI » Sat Jan 30, 2021 6:50 pm

This happens to me every single time I mix to a wav, then load that wave into a new empty project. I set the new project tempo and time sig to match the imported file but no go. I have isolated the problem to the warp function. My fix is to double click the track itself once loaded then undo warping.

Honestly do not know why this happens, it must be a master setting somewhere that I have missed.

Mike
MX9 Pro Studio B 469, Dell XPS 8930 Core I9-9900 3.10 GHz, Windows 10 Pro 64-bit, 32GB RAM, Nvidia GeForce 2060, 1 and 2 TB SSD’s + 1 and 2 TB spinner sata’s, cookies and coffee

User avatar
tomsank
Posts: 7
Joined: Fri Jan 29, 2021 8:19 pm

Re: Tempo change on imported .wav file

Post by tomsank » Sat Jan 30, 2021 9:34 pm

Hey Mike, how's it going? It gives me hope that there is at least someone who knows what I'm talking about. lol. I'm new to Mixcraft, so there are a lot of things that I haven't explored yet; for example, I hadn't even noticed "warp" until you mentioned it just now, although now it is pretty obviously right in the middle of the page and hard to miss once you notice it. What is it? What does it do? More importantly, how do you get it to stop interfering? I see now that, when I drag a wav file into the project, it is automatically selected. I can turn it off at that point, but the damage is already done (if that is what is causing the issue). I have a track that has been assigned a random tempo and turning it off doesn't seem to revert the track to its original speed.

I can kind of work around the issue if I just abandon control of the tempo to whatever file I first bring into an empty project, but when every single track wants to claim a different tempo it becomes dicey, to say the least. I agree that there has to be a master setting somewhere - -its got to be something simple - but I am using all default settings; I've only been using this for maybe two weeks. And half that time was waiting for new memory cards to bump up the RAM. :)

What I find more surprising is that nobody seems to recognize the issue, at least as I describe it, and I can't find a thread on the boards about it. Again, I am somewhat comforted that someone else feels my pain. At least it's not all in my head.

User avatar
Rolling Estonian
Posts: 1807
Joined: Sun Jan 11, 2015 9:42 am
Location: MD/DC

Re: Tempo change on imported .wav file

Post by Rolling Estonian » Sun Jan 31, 2021 6:39 am

Weekends are kind of slow but hang tight, I'm sure someone from MC will be piping in soon enough.

M

MikeDVI
Posts: 180
Joined: Thu Oct 17, 2013 1:23 pm

Re: Tempo change on imported .wav file

Post by MikeDVI » Sun Jan 31, 2021 7:38 am

Hey tomsank - Yes, I do feel your pain. It took me a little while of stumbling around and reading the manual references to get this working for me. I do not have "Auto beatmatch" option selected on my new projects - thought that was the culprit but the situation remained.

I am convinced it is an oversight on my (or "our") part, but I am listing the steps I take below in the order I do it for how I deal with this.

1) Create new empty project.
2) Set that new project tempo and time sig to match the imported track(s) from the mix they came from. In the case of changing tempos, I set to the initial tempo. (I use the automation line for tempo changes, you will get to that eventually if you ever need it.)
3) Drag wav(s) into new project. Line up imported tracks to the far left (start)
4) Now the wav's are loaded up, I click each one, go to the warp option which is usually showing red, and disable it.
5) Head to the left on the same screen, If incorrect then I set that tempo option there to match the current tempo as well.

Side note - Sometimes even when I import a track that has been recorded at a given tempo, the tempo in that window at the left shows something odd, like in this song my tempo is 126. The imported track was 126. But when I imported the track that "Original clip tempo" number showed like 86.52 or similar. This is typical of what happens to me, and yes, multiple tracks sometimes are all over the map. I suppose the "use project tempo" tab would work, but I do it manually to make sure.

See pic showing the areas I am talking about.

Hope this helps!!!

Mike
Attachments
InkedInkedMX9 Warp_LI.jpg
InkedInkedMX9 Warp_LI.jpg (207.1 KiB) Viewed 1542 times
MX9 Pro Studio B 469, Dell XPS 8930 Core I9-9900 3.10 GHz, Windows 10 Pro 64-bit, 32GB RAM, Nvidia GeForce 2060, 1 and 2 TB SSD’s + 1 and 2 TB spinner sata’s, cookies and coffee

User avatar
tomsank
Posts: 7
Joined: Fri Jan 29, 2021 8:19 pm

Re: Tempo change on imported .wav file

Post by tomsank » Sun Jan 31, 2021 8:46 am

Thanks - I'll try it this afternoon and see if it works for me. Right now, I have to finish a mix yesterday and so don't have time to experiment. I'll let you know what happens. thanks again!

bigaquarium
Posts: 564
Joined: Thu Nov 16, 2017 3:21 am

Re: Tempo change on imported .wav file

Post by bigaquarium » Mon Feb 01, 2021 12:31 am

Just out of curiosity, is there some reason why you didn't just bounce the tracks in place? You can right click any track in the list and select "Mix to new audio track", and Mixcraft will mix the track down, mute it, and place the WAV in a new track right next to it without needing to import anything. There is also the option to Freeze the track (CTRL-F) that accomplishes the same thing, albeit in the background.
youtube.com/c/fansofmixcraft
soundcloud.com/fansofmixcraft

User avatar
tomsank
Posts: 7
Joined: Fri Jan 29, 2021 8:19 pm

Re: Tempo change on imported .wav file

Post by tomsank » Mon Feb 01, 2021 1:20 am

@bigaquarium - Excellent question! It is because I haven't yet figured out how to do this. I see that I can convert one track at a time to an audio track, but I haven't understood how to bounce and mix several tracks together into a single audio track. I have a lot of work, so I just threw Mixcraft into the mix (no pun intended), in a sink or swim capacity. When things slow down a bit, I intend on watching all of the videos and manuals but, yes, that would be the logical solution - to bounce them onto one track without exporting to begin with.

Post Reply