MIDI instrument change not "sticky"

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Chris, Acoustica Eric, Acoustica Dan, Acoustica Greg

Post Reply
Killer
Posts: 10
Joined: Thu Sep 28, 2006 8:10 am

MIDI instrument change not "sticky"

Post by Killer » Sun Oct 11, 2009 4:48 pm

Hi

I thought I'd posted this a while back and got an answer, but the solution I'm thinking of isn't working!?!?! Maybe my mind's not working?


Anyhoo: I have imported a midi file and want to change the instrument. This works OK until I play again when the original instrument is played back. For example, if I have an acoustic piano, change it to play electric guitar, when I replay it, the sound reverts to the acoustic piano.

I THOUGHT the solution was to select the sound file, go to the Program change option, and then a right-click gave me an option (can't remember what it was, but it was obvious when you saw it!). Doing that is now not giving me any options that will get the result I want.

Can anyone help? Basically you can ignore the above if it doesn't make sense, if you can show me how to get the new instrument to "stick".

I hope this makes some sense!

Cheers

Killer

User avatar
Acoustica Greg
Posts: 21798
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Post by Acoustica Greg » Mon Oct 12, 2009 11:43 am

Hi,

You're on the right track. Right-click to "Delete Controller" for "Program Change." If that doesn't do the trick, do the same for the "Bank SElect" setting.

Either MIDI controller message can change the instrument on you.

Greg

Post Reply