Terrible Latency

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Dan, Acoustica Greg, Acoustica Chris, Acoustica Eric

Post Reply
Big Alex

Terrible Latency

Post by Big Alex » Thu Apr 06, 2006 11:58 am

Hi Guys,

My PC configuration is the following:

Celeron 1,1 Ghz with 640MB;
2 HDs: 20GB and 80GB
SoundBlaster Libe 24 bit sound Card
Windows 2K SP4

My main purpose is to record a guitar track over a mp3 backing track. A friend of mine did it and I found the overcome interesting.

Tried to do the same, using the PC mic ( arghhh I know I know...) to capture my guitar amplifier sound.

After recording, I could notice a terrible lack of sincronicity between the 2 tracks. Is it what people call latency?

After doing some research, some people advised me to install an ASIO driver to reduce the latency. Will this work?

Tried both 16 and 24 bit options without result

Is there any other way to elimitate this lack of sincronicity?

Thanks in advance

Guest

Post by Guest » Fri Apr 07, 2006 6:23 am

anybody?

User avatar
EL34
Posts: 724
Joined: Sun Mar 26, 2006 5:25 am
Location: Pisgah Forest, NC
Contact:

Post by EL34 » Fri Apr 07, 2006 9:01 am

I don't know what it is, it works fine here.

Maybe Eric can help, standby.

If I had to guess, this sort of thing is always hardware related.
Download the most recent driver for your soundcard, don't use the stock win 2K driver.

You don't use ASIO for what you are doing.

User avatar
Acoustica Greg
Posts: 19752
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Post by Acoustica Greg » Fri Apr 07, 2006 11:36 am

Hi,

First, make sure you've got version 2.5 build 48, because changes were made in recent updates to reduce latency. The latest version of Mixcraft is here.

Next, give your computer a fresh restart if you haven't shut and down and restarted lately. Close any unnecessary background programs while you are recording. Anything that is hitting the hard drive or using up memory.

You can also check to make sure you've got the correct recording and playback device selected in Mixcraft. Click on the File menu, choose Preferences, and look at the Recording and Playback tabs to verify that the correct sound card device is selected. Sometimes, other programs will set themselves up as your default audio device and you'll end up with delays in sound processing.

Finally, make sure you've got the latest updated drivers for your SoundBlaster Live.

Greg

Guest

Post by Guest » Fri Apr 07, 2006 12:04 pm

Thanks Greg!!

I will try the version 2.5 tonight.

Also I will run msconfig and remove all the unnecessary programs from start up.

I'll return with news soon.

VirtualSoundWaves

Re: Terrible Latency

Post by VirtualSoundWaves » Mon Apr 10, 2006 7:44 am

Big Alex wrote:Hi Guys,

My PC configuration is the following:

Celeron 1,1 Ghz with 640MB;
2 HDs: 20GB and 80GB
SoundBlaster Libe 24 bit sound Card
Windows 2K SP4

My main purpose is to record a guitar track over a mp3 backing track. A friend of mine did it and I found the overcome interesting.

Tried to do the same, using the PC mic ( arghhh I know I know...) to capture my guitar amplifier sound.

After recording, I could notice a terrible lack of sincronicity between the 2 tracks. Is it what people call latency?

After doing some research, some people advised me to install an ASIO driver to reduce the latency. Will this work?

Tried both 16 and 24 bit options without result

Is there any other way to elimitate this lack of sincronicity?

Thanks in advance
-------------------------------------------------------------------------------------

Hi "Big Alex",

Most recently I ran across this same situation. I made sure that I had all of the latest drivers and still I had the same issue. I even took the mixcraft and loaded onto several other PC's that I had - even with the latest drivers. I tried every single option that was avail with the mixcraft software. Finally I started to to listen to each recording that was made with each PC and they all had one thing in common. the timing on the notes wer getting further apart on each page that would move foward. Atleast by 30ms (Milliseconds). If you have Mixcraft set up in so that you have all of your visual peaks paging every few minutes this may be the issue as I had discovered. Every page that moved foward, the timing was off by atleast 30ms times the amount of minutes that you have recorded. The cure that I found for this was by bringing everything onto one page. You can do this by going through the menu or after your first track recording, save it as a project, get out of the program, then re-launch the program. Normally it defaults everything to one page. After that, start recording your other tracks. This problem went away as I had applied this trick, but it appears that this is a bug in which I plan to notify Acoustica about. Hope this helps Alex!

Storm

Big Alex

Post by Big Alex » Sun Apr 16, 2006 7:20 pm

Thanks for the feedback. I┤ll give it a try!

User avatar
Acoustica Greg
Posts: 19752
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Post by Acoustica Greg » Tue Apr 18, 2006 12:04 pm

Hi Storm,

Can you get the same results by just zooming all the way out? Or do you actually have to save your project and reload it?

Greg

Smurf

Post by Smurf » Tue Apr 25, 2006 12:22 am

If it is not too late............If anyone is using a real Creative Soundblaster soundcard you need to try out the kX Project drivers. Hit the site and look to see if your card is listed. If it is, grab the kX Driver (3537 is the last one, and works well for me) and load it. It makes the SB usable for real time audio. If you don't have a real SB card, try out the ASIO4ALL driver. I have sed this with a few ESS and built in sound cards with OK results. Good Luck

Post Reply