Clicking and Popping in Mixcraft 9

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Chris, Acoustica Eric, Acoustica Dan, Acoustica Greg

Post Reply
Zeester
Posts: 2
Joined: Sat Aug 06, 2022 10:40 am

Clicking and Popping in Mixcraft 9

Post by Zeester » Sat Aug 06, 2022 11:25 am

After installing Mixcraft 9 on my laptop, I'm getting occasional popping and clicking sounds.
Meanwhile, the CPU use is staying below 15% during playback.
I'm using a Focusrite Scarlett 2i2 on ASIO as my Sound Device:
Sample rate: 44100
Buffer Size: 512
Can anyone help me figure out how to eliminate these glitchy sounds?
Here's a snapshot of my PC specs if needed:
http://speccy.piriform.com/results/yW3Y ... pJEOEaX5bJ

Thanks,

User avatar
trevlyns
Posts: 3111
Joined: Sun May 06, 2012 1:59 am
Location: Rhode Island

Re: Clicking and Popping in Mixcraft 9

Post by trevlyns » Sat Aug 06, 2022 11:48 am

Hi

Have you checked out this video?

https://www.youtube.com/watch?v=XMXz81p ... l=Mixcraft
Keep on trackin'

Trevor
Official OFC™ Founding Member
Win 10 Pro; MX9 Pro B470; AMD Ryzen 5 12 Core@3.90GHz; 32GB RAM
Focusrite Scarlett 2i2; Sennheiser HD650's
Customized Strat and P-Bass

Sample Projects: https://soundcloud.com/trevs_audio

Zeester
Posts: 2
Joined: Sat Aug 06, 2022 10:40 am

Re: Clicking and Popping in Mixcraft 9

Post by Zeester » Sun Aug 07, 2022 12:16 am

Hello. :)
Thanks for asking!
Yup, I have checked that video out.
I've tried everything it said, yet I still get these annoying clicking sounds.
I should also mention that it's a little subtle yet still noticeable.

Any ideas on what could be wrong?

hpharley90
Posts: 101
Joined: Sat Sep 12, 2015 3:07 pm
Location: Southern New England

Re: Clicking and Popping in Mixcraft 9

Post by hpharley90 » Mon Aug 08, 2022 1:50 pm

open preference .. sound devices...ASIO options...use devices preferred settings....uncheck box.....
try that

User avatar
Acoustica Greg
Posts: 22664
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: Clicking and Popping in Mixcraft 9

Post by Acoustica Greg » Mon Aug 08, 2022 4:12 pm

Hi,

And if that doesn't help, try increasing your latency or buffer settings. In ASIO mode, click Open Mixer to find the buffer settings.

Greg
Mixcraft - The Musician's DAW
Check out our Mixcraft University 101 video tutorials.

cactus-head
Posts: 464
Joined: Sat Sep 16, 2017 3:09 pm

Re: Clicking and Popping in Mixcraft 9

Post by cactus-head » Mon Aug 08, 2022 5:16 pm

Also try checking the cable. If you are using an adapter or extension on a USB cable, that could cause interference. Make sure you have good quality cables (without adapters) plugged into everything.

Check the VSTs you are using. Is the clicking and popping only happening when you are using certain instruments and/or effects?

There's an article here that may help:

https://www.sweetwater.com/sweetcare/ar ... -clicking/

User avatar
Sturdy
Posts: 62
Joined: Sun Jul 04, 2021 6:26 pm

Re: Clicking and Popping in Mixcraft 9

Post by Sturdy » Tue Aug 09, 2022 7:53 pm

It helps me to go into windows "power and sleep" setting and up my cpu to "best performance" or "high performance". On my machine there's clicking and popping caused by cpu trying to conserve power. I can have very low cpu use like you mention and get clicking and popping even when cpu usage shows as 10-20%. Changing to high performance helps alot for me. I normally switch back and forth between high performance and "balanced" when not doing audio to save power.

User avatar
Acoustica Greg
Posts: 22664
Joined: Wed Mar 01, 2006 5:30 pm
Location: California
Contact:

Re: Clicking and Popping in Mixcraft 9

Post by Acoustica Greg » Wed Aug 10, 2022 10:34 am

Laptops in particular tend have power-saving performance issues. Sometimes even just plugging them in helps.
Mixcraft - The Musician's DAW
Check out our Mixcraft University 101 video tutorials.

Post Reply