snap, crackle and pop..

Support and feedback for Acoustica's Mixcraft audio mixing software.

Moderators: Acoustica Chris, Acoustica Eric, Acoustica Dan, Acoustica Greg

Post Reply
hpharley90
Posts: 60
Joined: Sat Sep 12, 2015 3:07 pm

snap, crackle and pop..

Post by hpharley90 » Wed Nov 25, 2020 4:05 pm

i have been using mixcraft for a number of years and currently use Mixcraft 9 pro studio 64 bit. I hear a lot of snap crackle and pop during playbacks. is it Mixcraft?

GovernmentMule
Posts: 363
Joined: Thu Oct 30, 2014 3:58 pm

Re: snap, crackle and pop..

Post by GovernmentMule » Wed Nov 25, 2020 4:21 pm

You are going to have to give more info. Did it just start this? What is your computer specs? Did you just upgrade? What is your audio interface? Are you using ASIO?What about your project you are working on? Are there 4 tracks or 84 and how many effects are you using? ETC.

hpharley90
Posts: 60
Joined: Sat Sep 12, 2015 3:07 pm

Re: snap, crackle and pop..

Post by hpharley90 » Wed Nov 25, 2020 4:30 pm

GovernmentMule wrote:
Wed Nov 25, 2020 4:21 pm
You are going to have to give more info. Did it just start this? What is your computer specs? Did you just upgrade? What is your audio interface? Are you using ASIO?What about your project you are working on? Are there 4 tracks or 84 and how many effects are you using? ETC.
No it started long time ago and finally just narrowed it down to mixcraft.I meet all minimum specs by a lot. no i didn't just upgrade. I use a scarlett 2i2 3rd generation interface. yes ASIO. Maybe 6 tracks. I bring a a sound file from ezdrummer into mixcraft and on play back it has pops and poofs. it sucks.

GovernmentMule
Posts: 363
Joined: Thu Oct 30, 2014 3:58 pm

Re: snap, crackle and pop..

Post by GovernmentMule » Wed Nov 25, 2020 4:34 pm

What are your ASIO settings for your Scarlett?

hpharley90
Posts: 60
Joined: Sat Sep 12, 2015 3:07 pm

Re: snap, crackle and pop..

Post by hpharley90 » Wed Nov 25, 2020 5:11 pm

the sample rate was 44100. now its 48000.no change. is that what you asked?
Attachments
2020-11-25_19-09-26.jpg
2020-11-25_19-09-26.jpg (73.5 KiB) Viewed 671 times

User avatar
Rolling Estonian
Posts: 1774
Joined: Sun Jan 11, 2015 9:42 am
Location: MD/DC

Re: snap, crackle and pop..

Post by Rolling Estonian » Thu Nov 26, 2020 1:59 pm

Have you gone into Windows sound settings, set the Scarlet to default and settings to 24 bit and 48000 for both playback and recording. Those settings need to match what you have the Scarlet set to. Click off 'use preferred settings' and then match up to the windows settings.

M

GovernmentMule
Posts: 363
Joined: Thu Oct 30, 2014 3:58 pm

Re: snap, crackle and pop..

Post by GovernmentMule » Fri Nov 27, 2020 3:20 am

hpharley90 wrote:
Wed Nov 25, 2020 5:11 pm
the sample rate was 44100. now its 48000.no change. is that what you asked?
I was more interested in your buffer settings, normally you can increase your buffer size and get rid of pops and crackles. The downside to increasing it is you will have more latency when recording through your interface. You need to find your sweet spot.
Does the Scarlett have a control panel software option with settings in it?

Notice in this video at around 3:35 he brings up an option panel for the Scarlett and it has a buffer setting on it. This is in another DAW though so I do not know how to do it in Mixcraft.

https://www.youtube.com/watch?v=IIa0BFBDRa0

If you can find that setting slowly increase the buffer setting until the pops and crackles stop. (If this is your problem)

GovernmentMule
Posts: 363
Joined: Thu Oct 30, 2014 3:58 pm

Re: snap, crackle and pop..

Post by GovernmentMule » Fri Nov 27, 2020 3:29 am

Also you can go into your task manager and see if anything is running in the background taking up resources.

For instance about a year ago I bought a solid state drive and it installed a program that kept data on my new drive and ran in the background and made my tracks pop and crackle intermittently. So now every time I boot my computer I have to go in and turn it off.

hpharley90
Posts: 60
Joined: Sat Sep 12, 2015 3:07 pm

Re: snap, crackle and pop..

Post by hpharley90 » Fri Nov 27, 2020 8:46 am

Rolling Estonian wrote:
Thu Nov 26, 2020 1:59 pm
Have you gone into Windows sound settings, set the Scarlet to default and settings to 24 bit and 48000 for both playback and recording. Those settings need to match what you have the Scarlet set to. Click off 'use preferred settings' and then match up to the windows settings.

M
yes

hpharley90
Posts: 60
Joined: Sat Sep 12, 2015 3:07 pm

Re: snap, crackle and pop..

Post by hpharley90 » Fri Nov 27, 2020 9:02 am

GovernmentMule wrote:
Fri Nov 27, 2020 3:20 am
hpharley90 wrote:
Wed Nov 25, 2020 5:11 pm
the sample rate was 44100. now its 48000.no change. is that what you asked?
I was more interested in your buffer settings, normally you can increase your buffer size and get rid of pops and crackles. The downside to increasing it is you will have more latency when recording through your interface. You need to find your sweet spot.
Does the Scarlett have a control panel software option with settings in it?

Notice in this video at around 3:35 he brings up an option panel for the Scarlett and it has a buffer setting on it. This is in another DAW though so I do not know how to do it in Mixcraft.

https://www.youtube.com/watch?v=IIa0BFBDRa0

If you can find that setting slowly increase the buffer setting until the pops and crackles stop. (If this is your problem)
thank you....that seemed to be the problem..the buffer....i'm at 3.2 m/s and no popping....finally....thank you

I have to use sound devices under preferences in Mixcraft to change buffer settings.
mixcraft sound device.jpg
mixcraft sound device.jpg (94.7 KiB) Viewed 612 times

User avatar
Rolling Estonian
Posts: 1774
Joined: Sun Jan 11, 2015 9:42 am
Location: MD/DC

Re: snap, crackle and pop..

Post by Rolling Estonian » Fri Nov 27, 2020 3:31 pm

That's a real low buffer, 512 is sort of a decent, attainable for most, setting. If you're at 10ms latency that's pretty good.

M

User avatar
Mark Bliss
Posts: 7099
Joined: Fri Jan 20, 2012 3:59 pm
Location: Out there

Re: snap, crackle and pop..

Post by Mark Bliss » Fri Nov 27, 2020 4:08 pm

Yep, thats still pretty aggressive. You are likely to still have problems with "busy" projects at some point, even with a "hotrod" computer.
Signs are your on the right track to a solution though... :wink:
Stay in tune, Mark

My SOUNDCLOUD Page

hpharley90
Posts: 60
Joined: Sat Sep 12, 2015 3:07 pm

Re: snap, crackle and pop..

Post by hpharley90 » Fri Nov 27, 2020 4:40 pm

Mark Bliss wrote:
Fri Nov 27, 2020 4:08 pm
Yep, thats still pretty aggressive. You are likely to still have problems with "busy" projects at some point, even with a "hotrod" computer.
Signs are your on the right track to a solution though... :wink:
I'm glad I know what problem is and how to remedy.
For a couple of years I had buffer size set at 128.
All sorts of popping. I thought it was static electricity so I was going down that avenue. I was very wrong.
Thanks all.

Post Reply